| Contents | | Edit Note/Alarm | | Layers | | Settings | | Pictures | | Tray | | Print |

 

Active Desktop Calendar Workspace


Active Desktop Calendar - Workspace

Today's cell is highlighted with light-blue and currently selected cell (if not the same as today's) with light-yellow. You can use keyboard arrows for navigation, plus Home key to jump directly to today's date, Page Up/Down to go to previous/next month and Enter to open Editing Note dialog. Copying notes works both from the right click context menu and through standard keyboard shortcuts (Ctrl-C, Ctrl-V). Basically, you can paste any text you have on the clipboard and the program will automatically create a note for it.

Menus Bar

      Data

        Layers (Ctrl-L): Opens the dialog for managing data layers. See more details here.

        Backup: Opens the dialog with options for backing up data. The program keeps all its settings and data in a single database file. To backup that database file it is recommended that you let the program do that automatically. The default folder the program will use to save backup copies of its database file is the following:

        C:\Documents and Settings\<username>\My Documents\Active Desktop Calendar Backup\
        (on Windows XP)

        C:\Users\<username>\Documents\Active Desktop Calendar Backup\
        (on Windows 7 and Vista)

        Of course, you can change the backup folder and in that case the program will automatically transfer all backup copies to a new location. There is also an option to revert back to the default backup folder.

        You can choose how many backup copies the program should keep for you. One is the minimum and nine the maximum with older backup copies removed automatically to make place for new ones. Finally, you can also force saving a backup copy at any moment by clicking Save Backup Now.

        Restore: Opens the dialog with options for restoring data from a backup file. It is a fairly simple operation. First you open the backup file by clicking the Open Backup File button (by default the program will open the same folder where automatic backups are saved). After opening the backup file you will see some basic information about its contents. Then you choose what to restore from that file. Three options are offered there: "Restore Data + Settings", "Restore Data" and "Restore Settings". Finally you click on Restore button to complete the process. The program will close down by itself at that point so you will have to start it again. This is normal as restoring of data and/or settings actually takes place on the program's startup.

        NOTE: Keep in mind that restoring information this way means complete replacement of any information currently existing in the program (settings and/or data depending on what you chose to restore) with contents of the backup file. This operation can not be undone so you should use Restore option with full awareness of what you do.

        Export: Allows you to export your Notes, Tasks, Alarms and calendar icons within a time frame you specify. Please note that when you use exporting from this menu then the program will automatically export data from all enabled layers to the same file. If you want to export data from one particular layer then go to the layers dialog, select that layer and click Export layer data (exporting from layers dialog also works when you make multiple layer selection).

        Note: You can choose between three file formats here. One is Active Desktop Calendar's proprietary .ADC format and the other two are well-known iCal and comma separated values .CSV (Windows) formats supported by many programs.

        Note (iCal): On exporting data the program does not write your time zone information to exported ICS file.

        Import Calendar File: When importing select a data file that you want to import, click Open, adjust importing options if necessary and click Finish. By default the program will import all types of data from a file to a new layer. If you want to import data to an existing layer then switch to "Import to existing layer" option, choose the target layer and tell the program what to do in case of duplicates. Importing option currently recognizes the program's own data formats, .ADC that you get by exporting and .ADX that is the internal data layer file format, plus the iCal and comma separated values .CSV (Windows) formats.

        Note (CSV): If you want to import data from a CSV file please note that it has to be formatted in the same way as a CSV file exported from the program. That means it has to have the leading row with data field names in the same order. Export a CSV file to check how exactly it should look like and here is a single note example:
           "Subject", "Start Date", "Start Time", "Description", "End Date", "End Time", "All day event"
           "Meeting in Detroit","26-07-04","00:00:01","Meeting in Detroit","26-07-04","23:59:59","true"

        One more thing is very important to note. Dates in CSV file to import have to be written in the same format as in an exported file on the same computer because date format depends on the regional settings. That means if you export to CSV on a computer that has US regional settings and try to import it on a computer that has German regional settings the import will not succeed.

        Note (iCal): On importing data the program does not recalculate times available in an ICS file if your time zone is not the same as time zone in the ICS file.

        Import Contacts: To import contacts simply select external data source you want to import contacts from and click Import Contacts. The program will do the rest automatically.

        Note (Outlook): For successful import from Outlook it is essential that you do the following. Before clicking Import Contacts button make sure Outlook is started. After clicking Import Contacts switch temporarily to Outlook and allow access to its contacts, then go back to the program.

        Note (XML): Main purpose of this option is to allow you to transfer contacts from one installation of the program to the other. Of course, exported XML file with contacts can also serve as a backup file. If you select this option for importing and click Import Contacts the program will open the standard browsing dialog so you can select the XML file to import.

        Add Holidays: Use this option to import holidays for different countries. You can select any number of countries from the list of 22 available countries around the world. To achieve multiple selection simply click country-by-country and if you make a mistake with selection click the selected country again to unselect. At the end click Import Selected Calendars to complete the process.

        Note: Each calendar with holidays is added as a separate data layer so it can also be removed easily through the Layers dialog.

        Print Calendar (Ctrl+P): Use this option to print out a monthly calendar. See more details here.

        Print All Contacts: Use this option to print out all your contacts (to print out a single contact go to Contacts View, right click on that contact and choose Print contact option). See more details here.

        Print Notes/Tasks: Use this option to print out notes and/or tasks as a list. See more details here.

        Program Settings (Ctrl+S): Opens the Settings panel.

        Exit Program: Exits the program.

    View

        Notes Month View (Ctrl+N): Switches the workspace to Notes Month view.

        Notes Week View (Ctrl+7): Opens Notes Week View that shows calendar details for seven days in a row. The view is similar to Notes Day View (see below for details). You can access it from the main Notes Month View by clicking the WEEK button in the calendar navigation block. The Notes Week View option is also available in the cell context menu and as a keyboard shortcut by pressing Ctrl-7. Please note that you will need horizontal screen resolution of at least 1280 pixels to use the Notes Week View effectively. It simply has to be that wide to accomodate data for seven days.

        Notes 5-Days View (Ctrl+5): Opens Notes Week View with 5-days checkbox enabled so it shows calendar details for five days in a row instead of seven. You can access it from the main Notes Month View by clicking the 5-D button in the calendar navigation block. The Notes 5-Days View option is also available in the cell context menu and as a keyboard shortcut by pressing Ctrl-5.

        Notes Day View (Ctrl+1): Opens Notes Day View that shows calendar details for the currently selected date. The view lists all your daily notes with both their subjects in bold letters and bodies as normal text using the same font parameters you have for the Notes/Tasks Bar on the desktop. If there is an icon attached to a note then it appears to the left of the time frame column together with icons that are marking an enabled alarm and recurrence pattern for that note. Attached date icons will show up in the top left corner. 

        You can use navigation arrows to browse the calendar day-by-day without leaving the view or click New Note to create a new note for the currently selected date. The Day View displays free-time slots in the list if that option is enabled. There are actually five checkboxes that allow you to enable or disable various elements in the list of notes in the view. Those elements are note subject, note text (body), all-day events, alarms and free-time slots. By default the view shows notes from all enabled data layers, but you can also select one layer to get a filtered list showing only notes that belong to that selected layer.

        Tasks View (Ctrl+T): Switches the workspace to Tasks view.

        Contacts View (Ctrl+O): Switches the workspace to Contacts view.

        Desktop Pictures (Ctrl+D): This option allows you to add some of your pictures to the desktop on top of the background picture you may already have. See more details here.

        Enable Notes View Tooltips (Ctrl+W): Use this option to enable or disable tooltips that show complete subject/text of a note when mouse pointer is kept over it for a short while.

        Hide Shortcuts Bar: Use this option to hide or show the Shortcuts Bar. When the Shortcuts Bar is hidden you can access all its options either through the View menu (Notes Month View, Tasks View, Contacts View, Desktop Pictures) or through the Data menu (Layers, Print Calendar).

        Hide Toolbar: Use this option to hide or show the Toolbar. When the Toolbar is hidden you can access all its options through the Notes menu for notes options, Tasks menu for tasks options, Data menu to print the calendar and Help menu to access help files.

        Show Month/Week/5-Days/Day View on Start: With one of these options enabled the program will bring up the respective Notes View automatically each time it starts.

      Notes

        New Note: Opens a dialog for adding a new note. See more details here.

        New Alarm: Opens a dialog for adding a new alarm.

        Copy Note to Task: Choose this option to quickly make a new task from a selected note.

        Find (Ctrl+F): Performs a search through all notes text. Search is case insensitive.

        Find Next (F3): Repeats the last successful Find action.

        Go To Date (Ctrl+G): Automatically positions your Notes view to a specified date.

        Jump Through Time: Allows you to go forward or backward through time for the specified number of days or weeks. If using the "days" option then you can also choose to include the start date in count which means one day less compared to the usual practice (i.e. 7th day after a Saturday would not be Saturday, but Friday).

        Calculate Days Between: Allows you to find out how many days there are between two given dates. You can choose the calculation that includes or excludes end date from the count. The result includes the information about the number of weeks and how many working days (Mon-Fri) and weekend days (Sat-Sun) exist in the selected period.

        Attach Date Icon: Attaches icon of choice to selected date in the calendar. That icon will appear instead of regular date icon if calendar is set to be shown as icons on desktop.

        Remove Date Icon: Removes previously attached icon of selected date. Regular date icon will be shown on desktop.

        Edit: Edits selected note. If note selected for editing is an instance of repeating note you will be prompted to decide whether the original note and all of its instances should actually be edited or not. Editing just one instance of a repeating note is not possible.

        Delete (Del): Deletes selected note. If note selected for deletion is an instance of repeating note you will be prompted to decide whether the original note and all of its instances should actually be deleted or not. Deleting just one instance of a repeating note is not possible.

    Tasks

    New Task: Adds new task on the top or at the bottom of task list depending on the "Place new task" setting. Also automatically switches the workspace to Tasks view. If you are using data layers then choose the destination layer for your task from the list available just right of the Add Task button. Please note that the list shows only your own layers because you can not add or edit data in layers owned by other people.

    Edit (F2): Used for editing existing tasks.

    Copy Task to Note: Choose this option to quickly make a new note from a selected task.

    Set As Done (Ctrl+D): Marks an existing task as done.

    Move Up: Moves currently selected task up on the list.

    Move Down: Moves currently selected task down on the list.

    Move Top: Moves currently selected task to the top of the list.

    Move Bottom: Moves currently selected task to the bottom of the list.

    Delete Task (Del): Deletes currently selected task.

    Delete All Tasks: Deletes all tasks from all active layers.

    Delete All Done Tasks: Deletes all done tasks from all active layers.

    Contacts

    New Contact: Opens dialog for adding a new contact. To add new contact you can also click NEW button in the contacts navigation toolbar in the top-right corner of the main contacts workspace window.

    Find (Ctrl-F): The case insensitive search goes through all contact fields looking for text entered in the search box.

    Find Next (F3): Repeats the last successful Find action.

    Edit: Opens dialog for editing details of selected contact.

    Card view: Switches the program to show contacts as cards. To switch between card and list views you can also click C/L button in the contacts navigation toolbar in the top-right corner of the main contacts workspace window.

    List view: Switches the program to show contacts as the list. In the list view you can click on column names to change the sorting order. To switch between card and list views you can also click C/L button in the contacts navigation toolbar in the top-right corner of the main contacts workspace window.

    Delete Contact: Deletes selected contact.

    Delete All Contacts: Use this option only if you want to empty the address book and start from scratch.

      Help

        Help (F1): Opens the help file.

        Data Integration Wizard: Launches a wizard that helps new users transfer the information they already have in other programs into Active Desktop Calendar. Supported external data sources are MIcrosoft Outlook (appointments, tasks, contacts), Google Calendar, Microsoft Outlook Express (contacts) and Windows Address Book.

        Desktop Layout Picker: Opens a dialog box that allows you to quickly change calendar appearance on the desktop. Use this as a starting point to find a layout that you like the best and then fine tune it through the program's settings.

        Registration: Use this option to enter your registration data. When the registration dialog shows up type in your name and registration code and click Register. While typing the code pay attention to typw all 17 symbols without mistakes.

        View Errors Log: The program keeps track of important events regarding access to network data layers. Informations about lost connection with a layer file and successful reconnection are all written to a text log file that you can open in Notepad with this command.

        Clear Errors Log: Use this command to clear the log file for network layers access.

        Contact Technical Support: You can use this option to contact XemiComputers technical support with any questions you may have about the program.

        Visit Program Homepage: Takes you directly to Active Desktop Calendar homepage.

        About Active Desktop Calendar: Displays some basic information about the program.

        Tell a friend: If you want to spread a word about this program "Tell a friend" option is there to help you. It will open new email message in your default email client and set it with some basic information and a link to the program's homepage.

 

Toolbar

      New Note

      Opens a dialog for adding new notes. See more details here.

      New Alarm


        Opens a dialog simmilar to New Note one, but used only for adding alarms.

      Print


        Opens a dialog for printing monthly calendar. See more details here.

      Edit

    Edits selected note. If note selected for editing is an instance of repeating note you will be prompted to decide whether the original note and all of its instances should actually be edited or not. Editing just one instance of a repeating note is not possible.

    Find

    Performs a search through all notes text. Search is case insensitive.

    Go To Date

    Automatically positions your Notes view to a specified date.

    Delete

    Deletes selected note. If note selected for deletion is an instance of repeating note you will be prompted to decide whether the original note and all of its instances should actually be deleted or not. Deleting just one instance of a repeating note is not possible.

    New Task

      Adds new task on the top or at the bottom of task list depending on the "Place new task" setting. Also automatically switches the workspace to Tasks view.

    Edit

    Used for editing existing tasks.

    Set As Done

    Marks selected task as done. Task will appear in strike-through letters in task list on the desktop. Depending on the chosen setting a task marked as Done could go to the bottom of the task list automatically.

    Move Up

    Moves currently selected task up on the list.

    Move Down

    Moves currently selected task down on the list.

    Move Top

    Moves currently selected task to the top of the list.

    Move Bottom

    Moves currently selected task to the bottom of the list.

    Delete Task

    Deletes selected task (standard multiselect options are available).

    Help

    Opens the help file.

Data Layers

      Opens the dialog for managing data layers. See more details here.

Notes/Alarms

      Switches the Active Desktop Calendar workspace to Notes/Alarms view.

Tasks

      Switches the Active Desktop Calendar workspace to Tasks view.

Active Desktop Calendar - Tasks view

Contacts

      Switches the Active Desktop Calendar workspace to Contacts view.

Active Desktop Calendar - Contacts view

Desktop Pictures

      This option allows you to add some of your pictures to the desktop on top of the background picture you may already have. See more details here.

Settings
Notes Title Bar

    Notes View's title bar always displays the currently selected month. If a special icon is attached to the currently selected date, it is displayed in the left corner. To the right there are navigation options which are self explanatory. Single arrows for months, double for years and central button serves as Go to Today. The additional 1-D, 5-D and WEEK buttons open the Day, 5-Days and Week views respectively. Those views are designed to show you all calendar details for a given period.

    An extra button that appears just left of the navigation set opens a dialog box where you can change background and foreground colors for all components that form the calendar in Notes View. Default color scheme remains always available and you can also use "Save colors" and "Load colors" buttons to save and load custom color schemes you create by yourself. A custom color scheme is saved to a file with extension .xs03.

Note Fields

    Double clicking on the date title will automatically open Add Note dialog. Double clicking on an existing note will open Edit Note dialog, while right clicking on it will give you the options to either Edit or Delete the note.

    Right clicking anywhere within the date field or title will bring a drop down menu with the following options:

    Notes Day View: Opens Notes Day View that shows calendar details for the currently selected date. See under the View menu options above on this page for more details.

    Notes Week View: Opens Notes Week View that shows calendar details for seven days in a row. See under the View menu options above on this page for more details.

    New Note: Opens a dialog for adding a new note. See more details here.

    New Alarm: Opens a dialog for adding a new alarm.

    Find: Performs a search through all notes text. Search is case insensitive.

    Go to Date: Automatically positions your Notes view to a specified date.

    Jump Through Time: Allows you to go forward or backward through time for the specified number of days or weeks. If using the "days" option then you can also choose to include the start date in count which means one day less compared to the usual practice (i.e. 7th day after a Saturday would not be Saturday, but Friday).

    Calculate Days Between: Allows you to find out how many days there are between two given dates. You can choose the calculation that includes or excludes end date from the count. The result includes the information about the number of weeks and how many working days (Mon-Fri) and weekend days (Sat-Sun) exist in the selected period.

    Attach Date Icon: Attaches icon of choice to selected date in the calendar. That icon will appear instead of regular date icon if calendar is set to be shown as icons on desktop. Please note that the date icon must be stored in the primary layer. If you attempt to use this option and the primary layer is disabled you will have to go to Layers dialog first and enable the primary layer. One more important thing, if you use this option and you are sharing your primary layer with other people, the icon will not appear on their desktops.

    Remove Date Icon: Removes previously attached icon of selected date. Regular date icon will be shown on desktop.

    Paste: Use this option to paste text from the clipboard. The program will automatically open new note for you.

 

| Contents | | Edit Note/Alarm | | Layers | | Settings | | Pictures | | Tray | | Print |

Visit www.xemico.comtop of the page